On Wed, Oct 14, 2020 at 05:03:56PM +0200, Nicolas George wrote:
> lance.lmw...@gmail.com (12020-10-14):
> > From: Limin Wang <lance.lmw...@gmail.com>
> > 
> > Signed-off-by: Limin Wang <lance.lmw...@gmail.com>
> > ---
> >  libavformat/udp.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/libavformat/udp.c b/libavformat/udp.c
> > index 30d8041..ee5fa84 100644
> > --- a/libavformat/udp.c
> > +++ b/libavformat/udp.c
> > @@ -138,7 +138,7 @@ static const AVOption options[] = {
> >      { "connect",        "set if connect() should be called on socket",     
> > OFFSET(is_connected),   AV_OPT_TYPE_BOOL,   { .i64 =  0 },     0, 1,       
> > .flags = D|E },
> >      { "fifo_size",      "set the UDP receiving circular buffer size, 
> > expressed as a number of packets with size of 188 bytes", 
> > OFFSET(circular_buffer_size), AV_OPT_TYPE_INT, {.i64 = 7*4096}, 0, INT_MAX, 
> > D },
> >      { "overrun_nonfatal", "survive in case of UDP receiving circular 
> > buffer overrun", OFFSET(overrun_nonfatal), AV_OPT_TYPE_BOOL, {.i64 = 0}, 0, 
> > 1,    D },
> > -    { "timeout",        "set raise error timeout (only in read mode)",     
> > OFFSET(timeout),        AV_OPT_TYPE_INT,    { .i64 = 0 },      0, INT_MAX, 
> > D },
> 
> > +    { "timeout",        "set raise error timeout, in microseconds(only in 
> > read mode)",OFFSET(timeout),          AV_OPT_TYPE_INT,  {.i64 = 0}, 0, 
> > INT_MAX, D },
> 
> You broke spacing.

I'll break into two line to make it better.

> 
> I think it would be better to deprecate all these integer options and
> replace them by proper durations.

now too many use case and difficult to test all of them, so I prefer to make it 
clear for description instead of deprecated.
$grep timeout libavformat/*.c |grep AV_OPT_TYPE_INT |wc -l
18

> 
> >      { "sources",        "Source list",                                     
> > OFFSET(sources),        AV_OPT_TYPE_STRING, { .str = NULL },               
> > .flags = D|E },
> >      { "block",          "Block list",                                      
> > OFFSET(block),          AV_OPT_TYPE_STRING, { .str = NULL },               
> > .flags = D|E },
> >      { NULL }
> 
> Regards,
> 
> -- 
>   Nicolas George



-- 
Thanks,
Limin Wang
_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel

To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".

Reply via email to