Debargha Mukherjee <debargha <at> google.com> writes:

> -   if (avctx->profile != FF_PROFILE_UNKNOWN)
> -       enccfg.g_profile = avctx->profile;
> +    if (avctx->profile != FF_PROFILE_UNKNOWN) {
> +        enccfg.g_profile = avctx->profile;
> +    }

Please make this a separate patch, do not mix 
functional and cosmetic changes.

+#ifdef VPX_IMG_FMT_HIGHBITDEPTH
+    .pix_fmts       = (const enum AVPixelFormat[]){ AV_PIX_FMT_YUV420P,
+                                                    AV_PIX_FMT_YUV422P,
+                                                    AV_PIX_FMT_YUV444P,

+#else
+    .pix_fmts       = (const enum AVPixelFormat[]){ AV_PIX_FMT_YUV420P,
+                                                    AV_PIX_FMT_YUV422P,
+                                                    AV_PIX_FMT_YUV444P,

I don't think this is more readable than having 
#ifdef VPX_IMG_FMT_HIGHBITDEPTH in the middle of 
the list. Do you disagree?

Carl Eugen

_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

Reply via email to