On 2/19/22 5:45 PM, Andreas Rheinhardt wrote:
Stephen Hutchinson:
Addresses Coverity issue 1500290

Signed-off-by: Stephen Hutchinson <qyo...@gmail.com>
---
  libavformat/avisynth.c | 3 ++-
  1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/libavformat/avisynth.c b/libavformat/avisynth.c
index 03489f180f..cfb7b2a783 100644
--- a/libavformat/avisynth.c
+++ b/libavformat/avisynth.c
@@ -244,7 +244,8 @@ static int avisynth_create_stream_video(AVFormatContext *s, 
AVStream *st)
      AviSynthContext *avs = s->priv_data;
      const AVS_Map *avsmap;
      AVS_VideoFrame *frame;
-    int framedata, error;
+    int framedata = 0;
+    int error;
      int planar = 0; // 0: packed, 1: YUV, 2: Y8, 3: Planar RGB, 4: YUVA, 5: 
Planar RGBA
st->codecpar->codec_type = AVMEDIA_TYPE_VIDEO;

Looking at the naming in
https://github.com/AviSynth/AviSynthPlus/blob/master/avs_core/core/avisynth_c.cpp#L828
makes me believe that this variable is actually a frame number. If so,
it is misnamed and this could be fixed easily by just removing this
variable. Am I right?


It seems so. I think I was just going off of the way avs_get_frame was used in avisynth_read_packet_video (as I was also trying to see whether some of the other properties* should be read per-frame from within read_packet_video), but there's no need to do that with the simpler ones in avisynth_create_stream_video.

*related to timestamps or to HDR mastering information, but I'm thinking that's going to require adding an entire function to the demuxer to be able to set side metadata (at least for the HDR stuff, anyway).
_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel

To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".

Reply via email to