PR #22628 opened by DmitriiGershenkop
URL: https://code.ffmpeg.org/FFmpeg/FFmpeg/pulls/22628
Patch URL: https://code.ffmpeg.org/FFmpeg/FFmpeg/pulls/22628.patch

Using AMF interfaces in C can be cumbersome and visually difficult to process 
in some cases: i.e.: object->function(object, args). To improve code 
readability, a new macro is added. This commit is instrumental for future AMF 
integration refactoring and is required for AMF FRC Pull Request (see: #22617).


>From a593d9beb36f69e5f672daa59c3d7466f330a7a7 Mon Sep 17 00:00:00 2001
From: Dmitrii Gershenkop <[email protected]>
Date: Thu, 26 Mar 2026 16:35:12 +0100
Subject: [PATCH] avutil/hwcontext_amf: Add AMF_IFACE_CALL macro

Using AMF interfaces in C can be cumbersome and visually difficult to process 
in some cases: i.e.: object->function(object, args). To improve code 
readability, a new macro is added. This commit is instrumental for future AMF 
integration refactoring.
---
 libavutil/hwcontext_amf_internal.h | 1 +
 1 file changed, 1 insertion(+)

diff --git a/libavutil/hwcontext_amf_internal.h 
b/libavutil/hwcontext_amf_internal.h
index 79e7556bf5..020a64938c 100644
--- a/libavutil/hwcontext_amf_internal.h
+++ b/libavutil/hwcontext_amf_internal.h
@@ -40,5 +40,6 @@
 
 #define AMF_TIME_BASE_Q          (AVRational){1, AMF_SECOND}
 
+#define AMF_IFACE_CALL(this, function, ...) ((this)->pVtbl->function(this, 
##__VA_ARGS__))
 
 #endif /* AVUTIL_HWCONTEXT_AMF_INTERNAL_H */
-- 
2.52.0

_______________________________________________
ffmpeg-devel mailing list -- [email protected]
To unsubscribe send an email to [email protected]

Reply via email to