On Wed, 14 Oct 2015 20:23:30 +0200
Michael Niedermayer <michae...@gmx.at> wrote:

> From: Michael Niedermayer <mich...@niedermayer.cc>
> 
> The "loop" option is used in several demuxers (like img2dec) and muxers, 
> using the same name in ffmpeg_opt
> breaks them. Feel free to revert this and replace by any other solution or 
> rename both as preferred
> This is just as a quick fix to avoid the regression with existing command 
> lines and to have both named
> the same (which does not work)
> 
> Example:
> ./ffmpeg -loop 1 -i fate-suite/png1/lena-rgb24.png -t 1 test.avi
> will produce 25 frames with the img2dec loop but only 1 frame at 25fps with 
> the ffmpeg loop option
> 
> Signed-off-by: Michael Niedermayer <mich...@niedermayer.cc>
> ---
>  ffmpeg_opt.c |    2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/ffmpeg_opt.c b/ffmpeg_opt.c
> index 573da72..b99a75a 100644
> --- a/ffmpeg_opt.c
> +++ b/ffmpeg_opt.c
> @@ -3158,7 +3158,7 @@ const OptionDef options[] = {
>      { "dump_attachment", HAS_ARG | OPT_STRING | OPT_SPEC |
>                           OPT_EXPERT | OPT_INPUT,                     { .off 
> = OFFSET(dump_attachment) },
>          "extract an attachment into a file", "filename" },
> -    { "loop", OPT_INT | HAS_ARG | OPT_EXPERT | OPT_INPUT |
> +    { "loop2", OPT_INT | HAS_ARG | OPT_EXPERT | OPT_INPUT |
>                          OPT_OFFSET,                                  { .off 
> = OFFSET(loop) }, "set number of times input stream shall be looped", "loop 
> count" },
>      { "debug_ts",       OPT_BOOL | OPT_EXPERT,                       { 
> &debug_ts },
>          "print timestamp debugging info" },

"loop2" is a confusing and ridiculous name.
_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

Reply via email to