On Thu, Jan 14, 2016 at 9:27 PM, James Darnley <james.darn...@gmail.com> wrote:
> On 2016-01-14 20:21, Henrik Gramner wrote:
>> xmN can be used unconditionally which gets rid of the %else. E.g.
>>
>>     movu       xm1, [yq+widthq*2]
>> %if cpuflag(avx2)
>>     vinserti128 m1, m1, [yq+widthq*2+12], 1
>> %endif
>
> I can change that.  I slightly prefer to not mix register sizes like
> that but it seems unavoidable with avx2.

The xmN notation was invented for code like this and I don't really
think that there's anything negative with using it. Reducing the
amount of %if/%else makes stuff easier to read.

It assembles into mmN with INIT_MMX, and xmmN with INIT_XMM and INIT_YMM.
_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

Reply via email to