I just encountered something very bizarre.  I have a java VO called
DateSpans...it's a class that simply contains a whole set of variations
of date spans available for a portfolio the user selects and I use this
class to dynamically set the calendar component in my flex app.  

The DateSpans class is populated by a procedure in the database and then
I send the DateSpans VO back to my Flex delegate class and use it
accordingly in my app.  An example of some of the fields of this VO is 

...
previousMTDFromDate
mTDFromDate
mTDToDate
previousQTDFromDate
qTDFromDate
qTDToDate
...

I have a corresponding ActionScript VO that has all the same fields.
Well, in my Flex app, I would retrieve the previousMTDFromDate and it
would work...then when I went to retrieve the mTDFromDate or the
mTDToDate, I would get an undefined returned to me.  I have 25 other
fields that I use and they were all turning back the date to me
correctly...except for the ones that were named starting with yTD, mTD,
qTD.  It wasn't until I actually went through the fields in both VOs and
renamed those fields to:

...
mtdFromDate
mtdToDate
qtdFromDate
qtdToDate
ytdFromDate
ytdToDate
...

That I started getting the returned item I was successfully getting from
the other fields...is there some issue with a naming convention with
fields that start with only one lowercase letter?  I SWEAR all I did was
rename the fields to the examples above from qTDFromDate to qtdFromDate
and so on and that fixed my problem.  I thought I was going crazy...I
was watching Java set the variables and I was calling them to
doublecheck right before I sent the DateSpans object back to my
ActionScript delegate class and all the info was there as I expected it
to be for every field in the VO...and as soon as I entered the delegate
I was printing out these fields...everything was properly set except for
the ones that started with a single lowercase letter followed by a
series of capital letters...isn't that bizarre?  I named them initially
that way just for function naming sake so the functions would be
setMTDFromDate, getMTDToDate, etc just for ease of readability...but now
they're all setMtdFromDate, getMtdToDate, which isn't the end of the
world but I think this is kind of a funny behavior...am I missing
something?

Robert L. Brueckmann
Senior Web Developer
Merlin Securities, LLC
595 Madison Avenue
New York, NY 10022
p: 212.822.4821
f: 212.822.4820
 
--------------------------------------------------------

This message contains information from Merlin Securities, LLC, or from one of 
its affiliates, that may be confidential and privileged. If you are not an 
intended recipient, please refrain from any disclosure, copying, distribution 
or use of this information and note that such actions are prohibited. If you 
have received this transmission in error, please notify the sender immediately 
by telephone or by replying to this transmission.
 
Merlin Securities, LLC is a registered broker-dealer. Services offered through 
Merlin Securities, LLC are not insured by the FDIC or any other Federal 
Government Agency, are not deposits of or guaranteed by Merlin Securities, LLC 
and may lose value. Nothing in this communication shall constitute a 
solicitation or recommendation to buy or sell a particular security.


 
Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/flexcoders/

<*> To unsubscribe from this group, send an email to:
    [EMAIL PROTECTED]

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/
 


Reply via email to