On Wed, 2001-11-28 at 21:46, BERNDT, JON S. (JON) (JSC-EX) (LM) wrote:
> > Also, automake is getting confused between JSBSim.cpp (which contains
> > main()), and JSBSim.cxx (the FDM interface). At link time, it creates
> > the JSBSim.o, then overwrites it when it compiles the next one. Could
> > one or other of these files be renamed for clarity?
> 
> No chance. First (but not the greatest), is that we would lose CVS history
> on the file[s]. The automake/autoconf setup for FlightGear works very
> nicely, so I assume you are talking about an automake/autoconf setup for
> JSBSim development only. There is no need to even *look* at anything with a
> .cxx extension when dealing with JSBSim development. The JSBSim.cxx file is
> not compiled into the libJSBSim.a library in FlightGear compilation, either.
> Ignore this file.
> 

OK, that certainly makes things easier. Here's an updated top-level
Makefile.am.

BTW, you can rename without losing history. You just have to move the
RCS file in the CVS repository. And if theres no need to even *look* at
anything with a .cxx extension, why is it there at all? Probably just to
confuse dumb-asses like me :)

Sorry for all the stupid questions, but as a new user to JSBSim, I'm
just pointing out stuff I find strange from a new user point of view.
Often, there's a good rationale behind things, and other times, it's
'just the way it happened' and could probably be done better.

--
Ross
SUBDIRS = filtersjb

INCLUDES = \
	-Wall

lib_LIBRARIES = libJSBSim.a

libJSBSim_a_SOURCES = \
	FGAerodynamics.cpp \
	FGAerodynamics.h \
	FGAircraft.cpp \
	FGAircraft.h \
	FGAtmosphere.cpp \
	FGAtmosphere.h \
	FGAuxiliary.cpp \
	FGAuxiliary.h \
	FGCoefficient.cpp \
	FGCoefficient.h \
	FGColumnVector3.cpp \
	FGColumnVector3.h \
	FGColumnVector4.cpp \
	FGColumnVector4.h \
	FGConfigFile.cpp \
	FGConfigFile.h \
	FGDefs.h \
	FGEngine.cpp \
	FGEngine.h \
	FGFactorGroup.cpp \
	FGFactorGroup.h \
	FGFCS.cpp \
	FGFCS.h \
	FGFDMExec.cpp \
	FGFDMExec.h \
	FGfdmSocket.cpp \
	FGfdmSocket.h \
	FGForce.cpp \
	FGForce.h \
	FGGroundReactions.cpp \
	FGGroundReactions.h \
	FGInertial.cpp \
	FGInertial.h \
	FGInitialCondition.cpp \
	FGInitialCondition.h \
	FGJSBBase.cpp \
	FGJSBBase.h \
	FGLGear.cpp \
	FGLGear.h \
	FGMassBalance.cpp \
	FGMassBalance.h \
	FGMatrix33.cpp \
	FGMatrix33.h \
	FGModel.cpp \
	FGModel.h \
	FGNozzle.cpp \
	FGNozzle.h \
	FGOutput.cpp \
	FGOutput.h \
	FGPiston.cpp \
	FGPiston.h \
	FGPosition.cpp \
	FGPosition.h \
	FGPropeller.cpp \
	FGPropeller.h \
	FGPropulsion.cpp \
	FGPropulsion.h \
	FGRocket.cpp \
	FGRocket.h \
	FGRotation.cpp \
	FGRotation.h \
	FGRotor.cpp \
	FGRotor.h \
	FGState.cpp \
	FGState.h \
	FGTable.cpp \
	FGTable.h \
	FGTank.cpp \
	FGTank.h \
	FGThruster.cpp \
	FGThruster.h \
	FGTranslation.cpp \
	FGTranslation.h \
	FGTrimAxis.cpp \
	FGTrimAxis.h \
	FGTrim.cpp \
	FGTrim.h \
	FGTurboJet.cpp \
	FGTurboJet.h \
	FGTurboProp.cpp \
	FGTurboProp.h \
	FGTurboShaft.cpp \
	FGTurboShaft.h \
	FGUtility.cpp \
	FGUtility.h \
	JSBSim.cxx

libJSBSim_a_LIBADD = \
	filtersjb/libFCSComponents.a

Reply via email to