I haven't looked at the code in question on this particular discussion
so this is not to criticize.

Overly concise variables names should be acceptable within limited
scope.
Calling an ObjectOutputStream oos may be sufficient when it's created
and destroyed within one little method.
Using i or z may suffice as loop counters within a single simple method,
while you may want a longer name simply to track the loop if it gets
more complex nesting loops.
A project should have defined standards for meaningful variable naming,
particularly when they're declared at the class level or they're public,
protected, or passed in to the method.

The simplest readability standard is of course the layout.  Eclipse has
plenty of preferences and an option to export them.  Line wraps, comment
format, etc should be consistant within a project.

Of course if code must be reused it helps if standard naming can be
enforced by such as abstract methods and interfaces.

-----Original Message-----
From: Peter Hancock [mailto:peter.hanc...@gmail.com] 
Sent: Wednesday, October 26, 2011 9:34 AM
To: fop-dev@xmlgraphics.apache.org
Subject: Re: Merge Request - Temp_ComplexScripts into Trunk

> I wonder what you think about the code in 
> o.a.f.hyphenation.TernaryTree, where the author apparently did not 
> know Java, and introduces the libc functions strcmp, strcpy, and 
> strlen, and which uses the Java char type (within the String type) for
coding tree pointers!

My apprehension about certain areas of your code (and not the
majority!) stems from such examples, and the headaches they    can
bring.  This is old code that I had no influence over at the time and I
do not want it to have any bearing on where the  project is heading.

> If you wanted to make a serious case against using short names, you 
> would start first by analyzing existing FOP usage and using such an 
> analysis to establish concrete metrics.

I do not think I have focused on the length of variable or member
names have I?  I did a PhD in mathematics and I have a     soft spot
for the aesthetic value of short names.  It is always pleasing to
distill a mathematical proof to the simplist     form possible and
using consise variable naming is often a part of that.  That said, I
do not think that working code        benefits from this approach:
what can seem like an efficient and powerful piece of code when
written can prove to be an      overly difficult thing to read later.
Unlike yourself, apparently, my memory ain't so good and I benefit from
code that has clear intention.

Peter

Reply via email to