On 08/19/2016 11:54 AM, Daniel Lobato Garcia wrote:
On 08/19, Lukas Zapletal wrote:
As discussed on IRC yesterday there should be consistency and there is an
option to autofix with rubocop if the style is changed to change existing
code with less effort.
TL;DR - Let's keep Rubocop away from rockethash thing.
What the consistency gives us? We all know there are two ways and both
will work. Let's avoid big bangs that will make cherry picking harder
and just let's slowly improve as the time goes on.
Not sure what cherry-picking becomes harder after this change? It's just
that people might have to rebase their PRs? That's a small price to pay
considering code is read 1000x more often than written.
Rebasing open PRs is fine. I think that bigger issue is cherry-picking
from devel to stable branches.
I see no point in changing a single line of code from old to new syntax
just for that. We should only change it when changing logic.
Even if Rubocop is able to check only for changed lines, I won't like
that at all. I do not want to switch my brain between Smart Proxy and
Foreman Core codebases. Both ways should work and be accepted. Let's
only make the old syntax preferable when reviewing and that's it.
Precisely that's the painpoint, reviewers shouldn't have to pay
attention to that. One of the points for having style guidelines is that
the code looks and reads as if it had been written by one person.
Think of it from the POV of the ocassional contributor who is just
confused about which syntax to use because the code mixes them both for
no reason.
I think we implemented Rubocop far beyond what's reasonable point. It
make sense for dangerous constructs, but not in this case (and few
others).
I'd argue the opposite, in foreman_docker or foreman_ansible I think
rubocop (with *all* cops enabled) helped maintain good coding standards
immensely and making the project *much easier* to read and get used to.
Again I think we're really bikeshedding when the purpose of a style
guide is to stop it and make code look more homogeneous
--
Later,
Lukas #lzap Zapletal
--
You received this message because you are subscribed to the Google Groups
"foreman-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to foreman-dev+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
--
Daniel Lobato Garcia
@dLobatog
blog.daniellobato.me
daniellobato.me
GPG: http://keys.gnupg.net/pks/lookup?op=get&search=0x7A92D6DD38D6DE30
Keybase: https://keybase.io/elobato
--
You received this message because you are subscribed to the Google Groups
"foreman-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to foreman-dev+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.