the C-style operators += etc. should better be written as  +:= since C has =
as assignment, Pascal has := as assignment symbol

:= means "assign to", += means "add to" etc., I cannot find any
inconsistency here.

Also, += and such were created to make it easier to convert C code. If you change this to +:= you do essentially two things:

1) Break existing code
2) Destroy any of the original purpose and usefulness of the thing in question.


_______________________________________________
fpc-devel maillist  -  fpc-devel@lists.freepascal.org
http://lists.freepascal.org/mailman/listinfo/fpc-devel

Reply via email to