I remember I heard about a mode switch that requires "type groups” (what are 
these called btw?) to use a . and be prefixed. For example:

type
        TGLType = (GL_FLOAT, GL_UNSIGNED_BYTE);


TGLType.GL_FLOAT would be the full name (note GL_FLOAT already is declared so I 
want the type to be explicitly TGLType.GL_FLOAT in all cases). I need to make 
some wrappers around OpenGL types and I thought this would be a nice way to do 
it instead of declaring a bunch of constants with prefixes but I just can’t 
remember how to handle that dot syntax (maybe it’s in the trunk under 
development). Thanks.

Regards,
        Ryan Joseph

_______________________________________________
fpc-pascal maillist  -  fpc-pascal@lists.freepascal.org
http://lists.freepascal.org/cgi-bin/mailman/listinfo/fpc-pascal

Reply via email to