On Thu, Jan 27, 2000 at 06:09:17PM -0800, Jordan K. Hubbard wrote:
> ===> libexec/getNAME
> cc -O -pipe   -I/usr/obj/usr/src/i386/usr/include -c /usr/src/libexec/getNAME/ge
> tNAME.c
> cc -O -pipe   -I/usr/obj/usr/src/i386/usr/include  -o getNAME getNAME.o
> gzip -cn /usr/src/libexec/getNAME/getNAME.1 > getNAME.1.gz
> ===> libexec/getty
> cc -O -pipe   -I/usr/obj/usr/src/i386/usr/include -c /usr/src/libexec/getty/main
> .c
> In file included from /usr/src/libexec/getty/main.c:71:
> /usr/src/libexec/getty/extern.h:61: conflicting types for `setflags'
> /usr/obj/usr/src/i386/usr/include/unistd.h:186: previous declaration of `setflag
> s'
> *** Error code 1
> ..
> 
> Guys, this is pretty bad!
> 
> - Jordan

>From the src/include/unistd.h cvs log:
------------------------
revision 1.33
date: 2000/01/27 21:16:51;  author: joe;  state: Exp;  lines: +3 -1
Historically file flags (schg, uschg, etc) have been converted from
string to u_long and back using two functions, flags_to_string and
string_to_flags, which co-existed with 'ls'.  As time has progressed
more and more other tools have used these private functions to
manipulate the file flags.

Recently I moved these functions from /usr/src/bin/ls to libutil,
but after some discussion with bde it's been decided that they
really ought to go in libc.

There are two already existing libc functions for manipulating file
modes:  setmode and getmode.  In keeping with these flags_to_string
has been renamed getflags and string_to_flags to setflags.
------------------------

This is the same kind of breakage I caused when moving some definitions
into unistd.h.  I would call it bootstrapping breakage, but others who know
the build system better claim it's avoidable.

Jason


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to