On 04/02/2012 05:05 PM, Rob Crittenden wrote:
Petr Viktorin wrote:
On 03/26/2012 10:44 PM, Rob Crittenden wrote:
Petr Viktorin wrote:
Patch 25 fixes errors I found by running pylint on the testsuite. They
were in code that was unused, either by error or because it only
runs on
errors.

Patch 26 adds a test for the batch plugin.

In patch 25 the second test_internal_error should really be
test_unauthorized_error. I think that is a clearer name. Otherwise looks
good.

Patch 26 needs a very minor rebase to fix an error caused by improved
error code handling:

expected = Fuzzy(u"invalid 'gidnumber'.*", <type 'unicode'>, None)
got = u"invalid 'gid': Gettext('must be an integer', domain='ipa',
localedir=None)"

I tested this:

diff --git a/tests/test_xmlrpc/test_batch_plugin.py
b/tests/test_xmlrpc/test_bat
ch_plugin.py
index e4280ed..d69bfd9 100644
--- a/tests/test_xmlrpc/test_batch_plugin.py
+++ b/tests/test_xmlrpc/test_batch_plugin.py
@@ -186,7 +186,7 @@ class test_batch(Declarative):
dict(error=u"'params' is required"),
dict(error=u"'givenname' is required"),
dict(error=u"'description' is required"),
- dict(error=Fuzzy(u"invalid 'gidnumber'.*")),
+ dict(error=Fuzzy(u"invalid 'gid'.*")),
),
),
),

rob

Thank you! Fixed, attaching updated patches.


These look ok but it is baffling to me why tuple needs to be added to
the Output format in batch. Do you know when it is being converted into
a tuple?

In XML-RPC unmarshalling, specifically ipalib/rpc.py:

109     if type(value) in (list, tuple):
110         return tuple(xml_unwrap(v, encoding) for v in value)

Maybe we should relax the validation? That's out of scope for this patch though.

The hbactest plugin has similar list/tuple Outputs.

--
PetrĀ³

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to