--- Dirk Meyer <[EMAIL PROTECTED]> escreveu: 
> Gustavo Sverzut Barbieri wrote:
> >  --- Dirk Meyer <[EMAIL PROTECTED]> escreveu: 
> >> Aubin Paul wrote:
> >> > Makes sense to me... Dischi's _debug_ command is a good example
> of
> >> how
> >> > we could do it.
> >> >
> >> > On Mon, Jan 05, 2004 at 08:03:12PM -0500, Michael Ruelle wrote:
> >> >> Ok i can see that. Maybe add a severity to the osd_message's
> and
> >> then we
> >> >> can have things show/ignore it based on a threshhold. Things
> like
> >> dead
> >> >> recordings, failed listings retrieval get a high priority but
> >> things
> >> >> like a failed weather lookup a low priority.
> >> 
> >> Thoughts:
> >> 
> >> o right now the slideshow should display all OSD_MESSAGES, because
> >>   it's handled inside the code. But the screensaver needs to
> ignore
> >>   these events, because they are not an event that should stop the
> >>   screensaver.
> >
> > I'm not sure here. Maybe one don't want to be disturbed while
> viewing
> > pictures (slideshow) and maybe the message should be shown in
> > screensaver.
> >    I would go for the same solution (code), but independant
> priority
> > settings for both screensaver and slideshow. Maybe others, like
> music
> > player or the Video Player.
> 
> Yes and no. OSD_MESSAGES is an event. It's send through rc.py to all
> parts of Freevo. The plugins like tinyosd should display the text or
> not. But this osd may not know if we have a slideshow or a
> screensaver (since screensaver may be a slideshow it's hard to tell).

Maybe it's better OSD (tinyosd) to call the running object to display
it. I mean, if it's in Menu, ask it to display the message. If it's in
MPlayer Music Player, ask it. If in MPlayer video player, ask it, ...
   With that we could have that I mentioned above and we solve the
problem that will be display the messages in Mplayer, Xine, TvTime, ...
   Maybe it could be a method in the basic plugin class. So just weired
plugins (video/mplayer, video/xine, ...) override it. 
   
   It seem to be more work, but it's the right way to do IMHO, since
each plugin is likely to know how to display info. In that case,
tinyosd should be the plugin that enqueue events and handle them. Maybe
it could be renamed to event_queue. If this happens we need to define
if the envent_queue calls plugins methods or plugins that ask for info.
I'm for the first.

 
> >> o priorities: maybe we need some kind of message logger. 
> >>   if messages: show item in main menu, after viewing, messages =
> []
> >>   if OSD_MESSAGE: messages += ( timestap, OSD_MESSAGE )
> >
> > Messages not shown will remain in the queue, right?
> > So we need some way to remove the message from the queue if they're
> not
> > valid anymore. Something like "Phone call from XXXX-YYYY" should go
> > away if the phone is answered, and likes. So we need a ID and a way
> to
> > force update the OSD.
> 
> Not so easy. Again, it's only an event. There may be a plugin storing
> the event. So the telephone example has two events: prio 0:
> ringing. If ringing stops and not answered, show prio 1: call from
> xxx missed. 

See above.


Gustavo

______________________________________________________________________

Conheça a nova central de informações anti-spam do Yahoo! Mail:
http://www.yahoo.com.br/antispam


-------------------------------------------------------
This SF.net email is sponsored by: Perforce Software.
Perforce is the Fast Software Configuration Management System offering
advanced branching capabilities and atomic changes on 50+ platforms.
Free Eval! http://www.perforce.com/perforce/loadprog.html
_______________________________________________
Freevo-devel mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/freevo-devel

Reply via email to