On 2008-01-14 10:22, Jason Tackaberry wrote:
> Ok, so the usage is:
>
>     some_yield_exec_func().signals['completed'].connect(my_handler)
>   

Actually no, nevermind.  some_yield_exec_func() will return InProgress.

I see now what you were actually saying.  And I suppose I buy your
argument that InProgress and Thread/Process is fundamentally different. 
I think exception_handler should be renamed to exception_signal, or
maybe just exception.  I think of a handler as an actual callback, not
something you connect a callback to.

How about a connect_both() convenience function for InProgress, allowing
you to connect handlers to both the result and exception.  It could be
used when you don't need to pass user args to the callbacks:

   some_yield_func().connect_both(my_handler, my_exc_handler)

-------------------------------------------------------------------------
Check out the new SourceForge.net Marketplace.
It's the best place to buy or sell services for
just about anything Open Source.
http://ad.doubleclick.net/clk;164216239;13503038;w?http://sf.net/marketplace
_______________________________________________
Freevo-devel mailing list
Freevo-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/freevo-devel

Reply via email to