I'd like to improve "dbReadLines" from br-search.boot
into the following:

--------
read_text_stream stream ==
  if stream then
    [read_line stream while not EOFP stream]

read_text_file filename ==
  handle_input_file(filename, function read_text_stream, [])
--------

It's more correct (closes stream when exception happens) and
function name is more generic (not limited to db operation.)

However I can't find a proper place to put this function.

I think current naming scheme under src/interp/ lacks tiering:
there should be files that are libraries used by other modules,
then there should be files making up module A/B/C, then there
should be higher structure like compiler/interpreter depends on
module A/B/C.

Anyway, I suggest to add a new file under src/interp/ that
contains commonly used library functions, including this one.

- Qian

--
You received this message because you are subscribed to the Google Groups "FriCAS - 
computer algebra system" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to fricas-devel+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/fricas-devel/0d509fa5-eaca-4a2d-8c6c-08624a4ffa0d%40gmail.com.

Reply via email to