Keeping this functionality in one class makes sense to me. The main change
we'd need to make to our code is changing lines like:

$db = Zend::registry('db');

to:

$db = Zend_Registry::registry('db');

I guess I could suggest simplifying the register/registry method names since
the duplication of the word "registry" is a little verbose. If this is in
its own class presumably this would be as good?..

$db = Zend_Registry::get('db');

and:

Zend_Registry::set('db', $db);

best wishes,
Si

Reply via email to