------- Comment #8 from dave dot korn dot cygwin at gmail dot com  2009-04-22 
11:34 -------
  Yep.  From the .ii file:


class gnu::classpath::Configuration : public ::java::lang::Object
{

  Configuration();
  static ::java::lang::String * classpath_home();
  static jboolean debug();
  static ::java::lang::String * toolkit();
  static ::java::lang::String * ecj();
public:
  static ::java::lang::String * CLASSPATH_HOME;
  static ::java::lang::String * CLASSPATH_VERSION;
  static jboolean 1;
  static const jboolean INIT_LOAD_LIBRARY = 0;
  static ::java::lang::String * default_awt_peer_toolkit;
  static const jboolean JAVA_LANG_SYSTEM_EXPLICIT_INITIALIZATION = 0;
  static ::java::lang::String * ECJ_JAR;
  static const jboolean WANT_NATIVE_BIG_INTEGER = 1;
  static ::java::lang::Class class$;
};
# 18 "/gnu/gcc/gcc/libjava/gnu/classpath/natConfiguration.cc" 2


Will look at whether we should not #define DEBUG in the first place, or more
likely it would be best to rename Configuration.DEBUG to something else
throughout (Configuration.JDEBUG sprints to mind).


-- 


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=38892

Reply via email to