https://gcc.gnu.org/bugzilla/show_bug.cgi?id=128068
Bug ID: 128068
Summary: Gimple_walk_operand api should be modernized
Product: gcc
Version: 17.0
Status: UNCONFIRMED
Keywords: internal-improvement
Severity: normal
Priority: P3
Component: tree-optimization
Assignee: pinskia at gcc dot gnu.org
Reporter: pinskia at gcc dot gnu.org
Target Milestone: ---
The gimple_walk_operand was created as a bridge from tree stmts to tuples but
never seemly fixed up to just do tuples.
So it has an odd callback which takes void* instead of the gimple_walk info
struct (naming is wrong as I am typing this from my phone).
I dont know if i am going have time to do this cleanup for 17. But I should
have time to get it ready for 18.