On Tue, 26 Apr 2011, Nick Clifton wrote:

> Similarly it would be nice to standard abbreviations for CUMULATIVE_ARGS, enum
> rtx_code, enum reg_class and const char *.  What do you think ?  I suspect

I think defining an abbreviation for const char * is actively bad, since 
const char * is a standard C idiom as-is and inventing local names for 
something with a standard C name should be avoided unless you are 
genuinely adding GCC-specific semantics.  (Yes, HOST_WIDEST_INT ought to 
be replaced by intmax_t/uintmax_t.)

My position on CUMULATIVE_ARGS remains that this type should become 
private to each back end and not visible in any code outside of config/ - 
with dynamic conversions from a target-independent type being used by the 
affected hooks.  (See PR 46500.)  Once the type is private to the back 
ends, they can also use a name other than CUMULATIVE_ARGS if they wish - 
but a typedef rather than a #define, please.

-- 
Joseph S. Myers
jos...@codesourcery.com

Reply via email to