On 05/23/2011 10:05 AM, Richard Guenther wrote:
> On Mon, May 23, 2011 at 3:53 PM, Nathan Froyd <froy...@codesourcery.com> 
> wrote:
>> +/* Return the Nth argument type from FNTYPE.  */
>> +
>> +tree
>> +nth_arg_type (const_tree fntype, int n)
>> +{
>> +  function_args_iterator iter;
>> +  tree t;
>> +  int i;
>> +
>> +  gcc_assert (fntype != NULL_TREE);
>> +  gcc_assert (n >= 0);
> 
> Please merge the asserts and do s/gcc_assert/gcc_checking_assert/

Ack.

> And if n should be >= 0 why not pass it in as unsigned?

Consistency with all the other interfaces where n is logically unsigned but
passed in as int?

> The patch is ok with both changes.

Thanks for the review.

-Nathan

Reply via email to