> From: Jeff Law [mailto:l...@redhat.com] > Sent: Saturday, April 25, 2015 2:57 AM
> > +static rtx > > +sign_extend_short_imm (rtx src, machine_mode mode, unsigned int > prec) > > +{ > > + if (GET_MODE_PRECISION (mode) < prec && CONST_INT_P (src) > > + && INTVAL (src) > 0 && val_signbit_known_set_p (mode, INTVAL > (src))) > > + src = GEN_INT (INTVAL (src) | ~GET_MODE_MASK (mode)); > Can you go ahead and put each condition of the && on a separate line. > It uses more vertical space, but IMHO makes this easier to read. As I > said, it was a nit :-) You're perfectly right. Anything that can improve readability of source code is a good thing. > > OK with that fix. Committed. Best regards, Thomas