On Thu, Sep 3, 2015 at 7:26 AM,  <tbsaunde+...@tbsaunde.org> wrote:
> From: Trevor Saunders <tbsaunde+...@tbsaunde.org>
>
> Hi,
>
> Personally I think hiding that variables are pointers is confusing, and I
> believe consensus is we should move away from this style.  So this series
> starts to do that.

Btw, what happened to the promised gimple -> gimple * conversion?

> patches individually bootstrapped + regtested on x86_64-linux-gnu, ok?

Leaving some time for others to start bikeshedding.

Richard.

> Trev
>
> Trevor Saunders (10):
>   don't typedef alias_set_entry and unhide pointerness
>   dse.c: remove some typedefs that hide pointerness
>   var-tracking.c: remove typedef of location_chain
>   var-tracking.c: remove typedef of shared_hash
>   bt-load.c: remove typedefs that hide pointerness
>   tree-ssa-ter.c: remove typedefs that hide pointerness
>   tree-vrp.c: remove typedefs that hide pointerness
>   dwarf2cfi.c: remove typedef that hides pointerness
>   dwarf2out.c: remove typedefs that hide pointerness
>   tree-ssa-loop-im.c: remove typedefs that hide pointerness
>
>  gcc/alias.c            |  31 +++--
>  gcc/bt-load.c          | 140 ++++++++++----------
>  gcc/dse.c              | 115 ++++++++---------
>  gcc/dwarf2cfi.c        |   5 +-
>  gcc/dwarf2out.c        | 340 
> ++++++++++++++++++++++++-------------------------
>  gcc/tree-ssa-loop-im.c |  98 +++++++-------
>  gcc/tree-ssa-ter.c     |  39 +++---
>  gcc/tree-vrp.c         |  22 ++--
>  gcc/var-tracking.c     | 192 ++++++++++++++--------------
>  9 files changed, 479 insertions(+), 503 deletions(-)
>
> --
> 2.4.0
>

Reply via email to