On Tue, Oct 06, 2015 at 02:40:26AM +0100, Kugan wrote: > > > On 05/10/15 21:33, James Greenhalgh wrote: > > On Thu, Oct 01, 2015 at 09:41:20PM +0100, Kugan wrote: > >> Hi, > >> > >> In "aarch64_get_lane<mode>" operand 0 is VEL, so for %<vwcore>0, > >> iterator vwcore should (?) support all the modes in VEL. > >> > >> Ran into following error with a local patch for an existing test case. > >> However it can also be reproduced with the attached test case. > >> > >> fnction ???fn1???: > >> t.c:25:1: internal compiler error: output_operand: invalid %-code > >> } > >> ^ > >> 0x8198fb output_operand_lossage(char const*, ...) > >> ../../base/gcc/final.c:3417 > >> 0x81a45b output_asm_insn(char const*, rtx_def**) > >> ../../base/gcc/final.c:3782 > >> 0x81b9d3 output_asm_insn(char const*, rtx_def**) > >> ../../base/gcc/final.c:2364 > >> 0x81b9d3 final_scan_insn(rtx_insn*, _IO_FILE*, int, int, int*) > >> ../../base/gcc/final.c:3029 > >> 0x81be2b final(rtx_insn*, _IO_FILE*, int) > >> ../../base/gcc/final.c:2058 > >> 0x81c6e7 rest_of_handle_final > >> ../../base/gcc/final.c:4449 > >> 0x81c6e7 execute > >> ../../base/gcc/final.c:4524 > >> > >> > >> Attached patch fixes this. Bootstrapped and regression tested for > >> aarch64-none-linux-gnu with no new regression. Is this OK for trunk? > >> > >> gcc/ChangeLog: > >> > >> 2015-10-02 Kugan Vivekanandarajah <kug...@linaro.org> > >> > >> * config/aarch64/iterators.md: Add missing core element mode for > >> mode. > >> > >> gcc/testsuite/ChangeLog: > >> > >> 2015-10-02 Kugan Vivekanandarajah <kug...@linaro.org> > >> > >> * gcc.target/aarch64/foo.c: New test. > >> > > > > "foo.c" is not OK, please give this testcase a meaningful name. > > > Renamed the test case. > > Is this OK now?
It still doesn't quite look right. For one, the attribute causing the ICE is "vwcore" not "vcore". How about calling the test gcc.target/aarch64/get_lane_f16_1.c ? > gcc/ChangeLog: > > 2015-10-06 Kugan Vivekanandarajah <kug...@linaro.org> > > * config/aarch64/iterators.md: Add missing core element mode for > mode. This ChangeLog entry is incomplete: * config/aarch64/iterators.md (vwcore): Add missing cases for V4HF/V8HF modes. > > gcc/testsuite/ChangeLog: > > 2015-10-06 Kugan Vivekanandarajah <kug...@linaro.org> > > * gcc.target/aarch64/vcore_ice_test.c: New test. > Please remeber to also update this with the new test name I suggested above. OK with those changes. Thanks, James