On Wed, Jun 08, 2016 at 03:57:42PM +0100, Bin Cheng wrote: > > From: James Greenhalgh <james.greenha...@arm.com> > > Sent: 31 May 2016 16:24 > > To: Bin Cheng > > Cc: gcc-patches@gcc.gnu.org; nd > > Subject: Re: [PATCH AArch64]Support missing vcond pattern by adding/using > > vec_cmp/vcond_mask patterns. > > > > On Tue, May 17, 2016 at 09:02:22AM +0000, Bin Cheng wrote: > > > Hi, > > > Alan and Renlin noticed that some vcond patterns are not supported in > > > AArch64(or AArch32?) backend, and they both had some patches fixing this. > > > After investigation, I agree with them that vcond/vcondu in AArch64's > > > backend > > > should be re-implemented using vec_cmp/vcond_mask patterns, so here comes > > > this patch which is based on Alan's. This patch supports all vcond/vcondu > > > patterns by implementing/using vec_cmp and vcond_mask patterns. > > > Different to > > > the original patch, it doesn't change GCC's expanding process, and it > > > keeps > > > vcond patterns. The patch also introduces vec_cmp*_internal to support > > > special case optimization for vcond/vcondu which current implementation > > > does. > > > Apart from Alan's patch, I also learned ideas from Renlin's, and it is my > > > change that shall be blamed if any potential bug is introduced. > > > > > > With this patch, GCC's test condition "vect_cond_mixed" can be enabled on > > > AArch64 (in a following patch). Bootstrap and test on AArch64. Is it OK? > > > BTW, this patch is necessary for gcc.dg/vect/PR56541.c (on AArch64) which > > > was > > > added before in tree if-conversion patch. > > > > Splitting this patch would have been very helpful. One patch each for the > > new standard pattern names, and one patch for the refactor of vcond. As > > it is, this patch is rather difficult to read. > Done, patch split into two with one implementing new vcond_mask&vec_cmp > patterns, and another re-writing vcond patterns. >
Hi Bin, Thanks for the changes. Just to make keeping track of review easier for me, would you mind resending these in series as two seperate emails. i.e. [Patch AArch64 1/2] Implement vcond_mask and vec_cmp patterns [Patch AArch64 2/2] Rewrite vcond patterns Thanks, James