On Tue, Sep 26, 2017 at 10:56 PM, Yuri Gribov <tetra2...@gmail.com> wrote: > Hi all, > > This patch fixes a trivial ICE in recent pattern. Bootstrapped and > regtested on x86_64. > > Ok to commit?
>+ bool cst_int_p = ! real_isnan (cst) && real_identical (&icst, cst); The GCC coding style says no space between the ! and the expression. Note for clarity I would put () around !real_isnan (cst) though. Other than that I don't see anything wrong with the patch (I cannot approve the patch though). Thanks, Andrew > > -Y