Hi!

On Wed, Feb 14, 2018 at 12:08:27PM -0800, Carl Love wrote:
> Per Segher's comments on the first version of the patch.  I split the
> patch into two.

Thanks, much easier to read.

>     2018-02-13  Carl Love  <c...@us.ibm.com>
> 
>         * config/rs6000/altivec.h: Add builtin names vec_extract4b
>         vec_insert4b.

        * config/rs6000/altivec.h (vec_extract4b, vec_insert4b): New.

(Similar for the rest of the changelog).

> --- a/gcc/config/rs6000/rs6000-c.c
> +++ b/gcc/config/rs6000/rs6000-c.c
> @@ -5433,6 +5433,8 @@ const struct altivec_builtin_types 
> altivec_overloaded_builtins[] = {
>      RS6000_BTI_INTDI, RS6000_BTI_V16QI, RS6000_BTI_UINTSI, 0 },
>    { P9V_BUILTIN_VEC_VEXTRACT4B, P9V_BUILTIN_VEXTRACT4B,
>      RS6000_BTI_INTDI, RS6000_BTI_unsigned_V16QI, RS6000_BTI_UINTSI, 0 },
> +  { P9V_BUILTIN_VEC_EXTRACT4B, P9V_BUILTIN_EXTRACT4B,
> +    RS6000_BTI_unsigned_V2DI, RS6000_BTI_unsigned_V16QI, RS6000_BTI_INTSI, 0 
> },

The old builtin use unsigned int for the element number (but signed is
correct, yes).

Looks good.  Okay for trunk.  Thanks!


Segher

Reply via email to