On 18/02/19 21:22 +0100, Jakub Jelinek wrote:
On Mon, Feb 18, 2019 at 09:15:39PM +0100, Rainer Orth wrote:
2019-02-15  Rainer Orth  <r...@cebitec.uni-bielefeld.de>

        * g++.dg/torture/pr89303.C (bad_weak_ptr): Rename to
        bad_weak_ptr_.

Ok, thanks.
If needed, guess we could rename much more (or rename the namespace in which
most of it is from std to my_std, though we'd need to check for stuff that
needs to be in std namespace).

I think that whole testcase could be in some non-std namespace. I
don't think there are any magic functions or types that need to be in
namespace std to work correctly.

# HG changeset patch
# Parent  056fe4093ce40dc462c6b50c3ae49df032a92230
Fix g++.dg/torture/pr89303.C with Solaris ld

diff --git a/gcc/testsuite/g++.dg/torture/pr89303.C 
b/gcc/testsuite/g++.dg/torture/pr89303.C
--- a/gcc/testsuite/g++.dg/torture/pr89303.C
+++ b/gcc/testsuite/g++.dg/torture/pr89303.C
@@ -350,11 +350,11 @@ namespace std
       { return static_cast<const _Tp*>(_M_addr()); }
     };

-  class bad_weak_ptr { };
+  class bad_weak_ptr_ { };

   inline void
   __throw_bad_weak_ptr()
-  { (throw (bad_weak_ptr())); }
+  { (throw (bad_weak_ptr_())); }

     class _Sp_counted_base
     {


        Jakub

Reply via email to