Hi!

On Mon, May 20, 2019 at 11:48:45AM +0200, Martin Liška wrote:
>       * config/rs6000/driver-rs6000.c (elf_platform): Do not use
>       an extra newline.
>       * config/rs6000/rs6000-c.c (SYNTAX_ERROR): Wrap pragma in %<%>.

Please say this is in rs6000_pragma_longcall.  You might want to move the
macro to inside the function, too.  Or get rid of it, for bonus points :-)

>       (rs6000_pragma_longcall): Likewise/

Typo (slash instead of dot).

>       (altivec_resolve_overloaded_builtin): Likewise for vec_lvs*.

Please spell out lvsl and lvsr.

>       * config/rs6000/rs6000.c (rs6000_option_override_internal):
>       Quote a C type.
>       (rs6000_function_arg): Likewise.
>       (rs6000_expand_set_fpscr_drn_builtin): Remove trailing dot.
>       (rs6000_expand_ternop_builtin): Use interval syntax.

I find that syntax less readable, btw.  Square brackets have a different
meaning already, in C programs.  Interval syntax isn't normally used for
integers, fwiw (you use set notation, like {0...15}, instead).  0..15
is all of shorter, more readable, and less confusing than [0,15] or
[0, 15] (ugh) or {0...15}.

So yeah, I disapprove of that.  But please do the same in rs6000 as in
the rest of the compiler ;-)


Okay for trunk, with the changelog nits, and Jakub's comment addressed.

Thanks,


Segher

Reply via email to