On Thu, May 23, 2019 at 08:56:23AM -0500, Bill Schmidt wrote:
> On 5/23/19 6:06 AM, Segher Boessenkool wrote:
> > On Wed, May 22, 2019 at 06:39:55PM -0500, Bill Schmidt wrote:
> >> @@ -26191,6 +26191,10 @@ rs6000_global_entry_point_needed_p (void)
> >>    if (TARGET_SINGLE_PIC_BASE)
> >>      return false;
> >>  
> >> +  /* PC-relative functions never generate a global entry point prologue.  
> >> */
> >> +  if (rs6000_pcrel_p (cfun))
> >> +    return false;
> > "global_entry_point_needed" is such a confusing name; it isn't what this
> > function is about.  "global entry point prologue" like in your comment
> > is much closer to the truth, but also not exactly it.
> >
> > Maybe we should rename this function.  And/or split it into two.
> I think "global entry point prologue" is exactly right, and the
> function-level comment even says that.  So we could change this to
> rs6000_global_entry_point_prologue_needed_p.  A bit chewy but digestible.

So I see the second use really needs the same condition...  okay.

What it checks is if the function needs a local entry point not equal to
the global entry point.

Anyway...  Not too important, the function isn't used in many places at all.


Segher

Reply via email to