Hi!

The usual way to write it would be:
On Thu, Jun 04, 2020 at 06:17:13AM +0000, Hao Liu OS wrote:
> gcc/:
> 
>         PR tree-optimization/89430
>         * tree-ssa-phiopt.c
>         (struct name_to_bb): Rename to ref_to_bb; add a new field exp;
>         remove ssa_name_ver, store, offset fields.
>         (struct ssa_names_hasher): Rename to refs_hasher; update functions.
>         (class nontrapping_dom_walker): Rename m_seen_ssa_names to 
> m_seen_refs.
>         (nontrapping_dom_walker::add_or_mark_expr): Extend to support 
> ARRAY_REFs
>         and COMPONENT_REFs.

        PR tree-optimization/89430
        * tree-ssa-phiopt.c (struct name_to_bb): Rename to ...
        (ref_to_bb): ... this.  Add a new field exp.  Remove ssa_name_ver,
        store, offset fields.
        (struct ssa_names_hasher): Rename to ...
        (refs_hasher): ... this.  Update methods.
        (class nontrapping_dom_walker): Rename m_seen_ssa_names to m_seen_refs.
        (nontrapping_dom_walker::add_or_mark_expr): Extend to support ARRAY_REFs
        and COMPONENT_REFs.
or so.

Will defer review to Richard.

        Jakub

Reply via email to