Jojo R <jiejie_r...@c-sky.com> writes:
> Jojo
> 在 2020年10月27日 +0800 PM10:14,Richard Sandiford <richard.sandif...@arm.com>,写道:
>> Jojo R <jiejie_r...@c-sky.com> writes:
>> > gcc/ChangeLog:
>> >
>> > * genemit.c (main): Print 'split line'.
>> > * Makefile.in (insn-emit.c): Define split count and file
>> >
>> > ---
>> > gcc/Makefile.in | 19 +++++++++
>> > gcc/genemit.c | 104 +++++++++++++++++++++++++++++-------------------
>> > 2 files changed, 83 insertions(+), 40 deletions(-)
>> >
>> > diff --git a/gcc/Makefile.in b/gcc/Makefile.in
>> > index 79e854aa938..a7fcc7d5949 100644
>> > --- a/gcc/Makefile.in
>> > +++ b/gcc/Makefile.in
>> > @@ -1258,6 +1258,21 @@ ANALYZER_OBJS = \
>> > # We put the *-match.o and insn-*.o files first so that a parallel make
>> > # will build them sooner, because they are large and otherwise tend to be
>> > # the last objects to finish building.
>> > +
>> > +# target overrides
>> > +-include $(tmake_file)
>> > +
>> > +INSN-GENERATED-SPLIT-NUM ?= 0
>> > +
>> > +insn-generated-split-num = $(shell i=1; j=`expr 
>> > $(INSN-GENERATED-SPLIT-NUM) + 1`; \
>> > + while test $$i -le $$j; do \
>> > + echo $$i; i=`expr $$i + 1`; \
>> > + done)
>> > +
>> > +insn-emit-split-c := $(foreach o, $(shell for i in 
>> > $(insn-generated-split-num); do echo $$i; done), insn-emit$(o).c)
>> > +insn-emit-split-obj = $(patsubst %.c,%.o, $(insn-emit-split-c))
>> > +$(insn-emit-split-c): insn-emit.c
>>
>> Sorry for the slow reply. I stand by what I said in
>> https://gcc.gnu.org/pipermail/gcc-patches/2020-August/552863.html:
>>
>> I think we should use the same wordlist technique as check_p_numbers[0-6].
>> So I guess the first step would be to rename check_p_numbers[0-6] to
>> something more general and use it both here and in check_p_numbers.
>>
>> I think that would be better than having two different ways of
>> generating lists of numbers, one directly in make and one calling
>> out to the shell. But I didn't want to reassert that comment in
>> case anyone was prepared to approve the patch in its current form.
>>
>
> Ok & Thanks.
>
> It’s fixed in patch v8.

Thanks.  Like I say, I think we should rename check_p_numbers* at the
same time, since it's now used for more than just parallel check.  Maybe
s/check_p_numbers/number_series/.

But otherwise it looks good.

>> BTW, do you have a copyright assignment on file?
>
> I email the patch without copyright, and I think it is same with other gcc 
> community patch.

Some changes can be so small and mechanical that they're not in practice
copyrightable, but all other changes need a copyright assignment.
Unfortunately this patch is too complex to fall into the first category.
See:

  https://gcc.gnu.org/contribute.html#legal

for more details about the requirement and process.

Thanks,
Richard

Reply via email to