Hi!

On Thu, Jul 29, 2021 at 08:31:02AM -0500, Bill Schmidt wrote:
>       * config/rs6000/rs6000-call.c (rs6000-builtins.h): New #include.
>       (rs6000_init_builtins): Call rs6000_autoinit_builtins; skip the old
>       initialization logic when new builtins are enabled.

s/; s/.  S/

> +  /* Execute the autogenerated initialization code for builtins.  */
> +  rs6000_autoinit_builtins ();

The name "autoinit" isn't so great (what "self" does this "auto" refer
to?), but perhaps some later patch fixes this up?  It is minor of
course, but the bigger something is, the better name that it deserves.
Names shape thoughts, and we should make the architecture of our code as
clear as possible.

> +#ifdef SUBTARGET_INIT_BUILTINS
> +      SUBTARGET_INIT_BUILTINS;
> +#endif

Let's see how this shapes up.  Preferably we won't have an #ifdef but
an empty macro (or a "do {} while (0)"), etc.

Okay for trunk, if this is revisited later.  Thanks!


Segher

Reply via email to