On Tue, Nov 15, 2022 at 2:52 PM Aldy Hernandez <al...@redhat.com> wrote: > > On Mon, Nov 14, 2022 at 10:12 AM Richard Biener > <richard.guent...@gmail.com> wrote: > > > > On Sat, Nov 12, 2022 at 7:30 PM Aldy Hernandez <al...@redhat.com> wrote: > > > > > > It irks me that a PR named "we should track ranges for floating-point > > > hasn't been closed in this release. This is an attempt to do just > > > that. > > > > > > As mentioned in the PR, even though we track ranges for floats, it has > > > been suggested that avoiding recursing through SSA defs in > > > gimple_assign_nonnegative_warnv_p is also a goal. We can do this with > > > various ranger components without the need for a heavy handed approach > > > (i.e. a full ranger). > > > > > > I have implemented two versions of known_float_sign_p() that answer > > > the question whether we definitely know the sign for an operation or a > > > tree expression. > > > > > > Both versions use get_global_range_query, which is a wrapper to query > > > global ranges. This means, that no caching or propagation is done. > > > In the case of an SSA, we just return the global range for it (think > > > SSA_NAME_RANGE_INFO). In the case of a tree code with operands, we > > > also use get_global_range_query to resolve the operands, and then call > > > into range-ops, which is our lowest level component. There is no > > > ranger or gori involved. All we're doing is resolving the operation > > > with the ranges passed. > > > > > > This is enough to avoid recursing in the case where we definitely know > > > the sign of a range. Otherwise, we still recurse. > > > > > > Note that instead of get_global_range_query(), we could use > > > get_range_query() which uses a ranger (if active in a pass), or > > > get_global_range_query if not. This would allow passes that have an > > > active ranger (with enable_ranger) to use a full ranger. These passes > > > are currently, VRP, loop unswitching, DOM, loop versioning, etc. If > > > no ranger is active, get_range_query defaults to global ranges, so > > > there's no additional penalty. > > > > > > Would this be acceptable, at least enough to close (or rename the PR ;-))? > > > > I think the checks would belong to the gimple_stmt_nonnegative_warnv_p > > function > > only (that's the SSA name entry from the fold-const.cc ones)? > > > > I also notice the use of 'bool' for the "sign". That's not really > > descriptive. We > > have SIGNED and UNSIGNED (aka enum signop), not sure if that's the > > perfect match vs. NEGATIVE and NONNEGATIVE. Maybe the functions > > name is just bad and they should be known_float_negative_p? > > Yeah, SIGNED and UNSIGNED doesn't seem to be much clearer than "bool signbit". > > For instance, we have the following in frange: > > void set_nan (tree type, bool sign); > void update_nan (bool sign); > bool maybe_isnan (bool sign) const; > bool signbit_p (bool &signbit) const; > > I'm OK changing them to enum signop if you prefer. I'm just not > totally convinced it's more readable. > > ??
I think when talking about 'signbit' or 'sign' the old usual 'unsigned' type is better than bool. signbit_p feels a bit redundant (the _p). We could have another enum like signop just I think the obvious candidates { POSITIVE, NEGATIVE } or { NEGATIVE, NONNEGATIVE } aren't too great. The obvious alternative is to follow the existing uns_p (unsigned?) parameters and not use bool sign but bool unsigned_p, there 'true' and 'false' are obvious. For 'signbit_p' it would then be bool signbit_p (unsigned &signbit) being the true value of the bit (and the return value indicates the UNKNOWN case). Richard. > > Aldy >