Hello!

Correct name of atomic "or" named pattern is "atomic_orM", not "atomic_iorM".

Attached patch fixes this oversight.

2012-04-17  Uros Bizjak  <ubiz...@gmail.com>

        PR target/53020
        * config/i386/sync.md (atomic_<code><mode>): Rename to
        atomic_<logic><mode>.

Patch was bootstrapped and tested on x86_64-pc-linux-gnu, will be
committed to all release branches.

Uros.
Index: config/i386/sync.md
===================================================================
--- config/i386/sync.md (revision 186539)
+++ config/i386/sync.md (working copy)
@@ -576,7 +576,7 @@
   return "lock{%;} sub{<imodesuffix>}\t{%1, %0|%0, %1}";
 })
 
-(define_insn "atomic_<code><mode>"
+(define_insn "atomic_<logic><mode>"
   [(set (match_operand:SWI 0 "memory_operand" "+m")
        (unspec_volatile:SWI
          [(any_logic:SWI (match_dup 0)

Reply via email to