On 27/03/2013, at 4:14 AM, Alexander Ivchenko wrote:

> Hi,
> 
> Since almost three months have passed I feel that I need to recheck the patch
> before commiting it. I fixed what Maxim mentioned and also I fixed:

The patch is OK with 2 changes:

1. s/default_have_ifunc_p/default_has_ifunc_p/
The new target hook is called "has_ifunc_p", so "has" in the name of its 
default implementation is more appropriate.

> 
> diff --git a/gcc/configure b/gcc/configure
> old mode 100755
> new mode 100644
> index eac96cd..928693a
> --- a/gcc/configure
> +++ b/gcc/configure
> @@ -22055,11 +22055,14 @@ else
>   enable_gnu_indirect_function="$default_gnu_indirect_function"
> fi
> 
> -if test x$enable_gnu_indirect_function = xyes; then
> 
> -$as_echo "#define HAVE_GNU_INDIRECT_FUNCTION 1" >>confdefs.h
> +gif=`if test $enable_gnu_indirect_function == yes; then echo 1; else
> echo 0; fi`

2. gif=`if test x$enable_gnu_indirect_function = xyes; then echo 1; else
echo 0; fi`

Note that canonical equality operator of 'test' is "=", not "==".  The 'x' 
before the variable is a good practice to handle empty definitions of shell 
variables (`if test = yes;` will produce an error).

Oh, and in the changelog you have a typo "linux-androids.h" -> 
"linux-android.h".

Otherwise OK.

Thanks,

--
Maxim Kuvyrkov
KugelWorks

Reply via email to