>>>>> On Sun, 18 Aug 2013, Ulrich Mueller wrote:

> For EAPI 6, introduction of a patch applying function to the package
> manager itself is being discussed. This would serve two purposes:
> - support for PATCHES variable in a default src_install phase
> - a function to apply user patches

> In bug 463768 the conclusion so far was that implementing the full
> epatch function in the package manager is not feasible. Therefore,
> the package manager's implemention would have reduced functionality.
> The current epatch() would remain available in eutils.eclass for
> cases where its more advanced modes of operation are needed.

> The feature list we came up with (see bug 463768 comment 32)
> includes support for regular patch files, of course. It also
> includes support for directories, with patches applied in lexical
> order of their filenames (only files named *.diff and *.patch).

> So, the questions that I'd like to ask are:

Summarising the answers below.

> 1. Is the above set of features reasonable?

Nobody has replied to this one, so I assume that there are no
objections.

> 2. Should the function do automatic -p* detection, or should it
>    default to -p1? Both would be overridable by an explicit -p*
>    option. There are good arguments for either variant 
>    (see the above-mentioned bug).

Rick "Zero_Chaos" Farina:
| Pretty please autodetection.  It's a very nice feature that we seem
| to already have sanely implemented.

Michael Orlitzky:
| With epatch() still available, my instinct is to leave the -p
| detection out of PMS for now. The implementation details will be
| messy otherwise, [...]

Michał Górny:
| I'm all for -p1. Instead of auto-detecting stuff on user's side,
| we should provide developers with a simple tool that would
| automatically 'fix' patches.

Not many new arguments, beyond what we had in the bug already. I'd
suggest that we follow the KISS principle and go with -p1. There's
always epatch if you need more fancy stuff.

> 3. So far, we don't have a good name for the function.

Only suggestion so far is "dopatch". I don't really like it because
other do* functions are called from src_install. But if nobody comes
up with a better name, then it will be dopatch.

Ulrich

Attachment: pgp8KqGzq44R0.pgp
Description: PGP signature

Reply via email to