Attention is currently required from: pespin.

osmith has posted comments on this change. ( 
https://gerrit.osmocom.org/c/libosmocore/+/35232?usp=email )

Change subject: socket: Reimplement osmo_sock_init2_multiaddr()
......................................................................


Patch Set 2: Code-Review+1

(4 comments)

Patchset:

PS2:
logic looks fine, just some cosmetics


File src/core/socket.c:

https://gerrit.osmocom.org/c/libosmocore/+/35232/comment/707ab214_70e3d9a9
PS2, Line 922: IPv4 or IPv6
IPv4-only or IPv6-only


https://gerrit.osmocom.org/c/libosmocore/+/35232/comment/c4fb0cd8_50b0b67d
PS2, Line 933:   * Both are checked here through "or" here to account for "bind 
flag set,
what do you mean with 'checked through "or" here', did you mean to write it 
like this?
```
if (loc_has_v6addr || rem_has_v6addr)
        family = AF_INET6;
else
        family = AF_INET;
```


https://gerrit.osmocom.org/c/libosmocore/+/35232/comment/1f5f1437_11cdfece
PS2, Line 945:      (loc_has_v4addr != rem_has_v4addr || loc_has_v6addr != 
rem_has_v6addr)) {
the if condition looks right, but is IMHO a bit hard to read, maybe move it / 
or the whole block here to a separate function?



--
To view, visit https://gerrit.osmocom.org/c/libosmocore/+/35232?usp=email
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Change-Id: I2641fbaca6f477404b094dbc53c0c1a3dd3fd2fd
Gerrit-Change-Number: 35232
Gerrit-PatchSet: 2
Gerrit-Owner: pespin <pes...@sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <lafo...@osmocom.org>
Gerrit-Reviewer: osmith <osm...@sysmocom.de>
Gerrit-Attention: pespin <pes...@sysmocom.de>
Gerrit-Comment-Date: Wed, 06 Dec 2023 07:26:48 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment

Reply via email to