Review at  https://gerrit.osmocom.org/5896

cosmetic: explicitly init ho_ref start value

The static ho_ref seems to be implicitly initialized to zero, but let's make it
explicit for code readability.

Change-Id: I00493bcb7ef3e38fb8e0077c60c5bac7199f1073
---
M src/libbsc/handover_logic.c
1 file changed, 1 insertion(+), 1 deletion(-)


  git pull ssh://gerrit.osmocom.org:29418/osmo-bsc refs/changes/96/5896/1

diff --git a/src/libbsc/handover_logic.c b/src/libbsc/handover_logic.c
index ee7b683..4b86de7 100644
--- a/src/libbsc/handover_logic.c
+++ b/src/libbsc/handover_logic.c
@@ -93,7 +93,7 @@
 {
        struct gsm_lchan *new_lchan;
        struct bsc_handover *ho;
-       static uint8_t ho_ref;
+       static uint8_t ho_ref = 0;
        int rc;
 
        /* don't attempt multiple handovers for the same lchan at

-- 
To view, visit https://gerrit.osmocom.org/5896
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I00493bcb7ef3e38fb8e0077c60c5bac7199f1073
Gerrit-PatchSet: 1
Gerrit-Project: osmo-bsc
Gerrit-Branch: master
Gerrit-Owner: Neels Hofmeyr <nhofm...@sysmocom.de>

Reply via email to