Patch Set 6: Code-Review-1

(1 comment)

https://gerrit.osmocom.org/#/c/6659/6/include/osmocom/gsm/gsm48.h
File include/osmocom/gsm/gsm48.h:

Line 37: void osmo_decode_lai(const struct gsm48_loc_area_id *lai, struct 
osmo_location_area_id *decoded);
now here we have functions specific to the encoding/decoding of GSM04.08 but 
there is no gsm48 in the name.  This is wrong.  A *generic* function not 
related to any spcecific encoding can just have an osmo_ prefix.  But a 
function for gsm04.08 should have osmo_gsm48 or (better, to align with existing 
API) simply gsm48_ prefix.


-- 
To view, visit https://gerrit.osmocom.org/6659
To unsubscribe, visit https://gerrit.osmocom.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Id2240f7f518494c9df6c8bda52c0d5092f90f221
Gerrit-PatchSet: 6
Gerrit-Project: libosmocore
Gerrit-Branch: master
Gerrit-Owner: Neels Hofmeyr <nhofm...@sysmocom.de>
Gerrit-Reviewer: Harald Welte <lafo...@gnumonks.org>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: Neels Hofmeyr <nhofm...@sysmocom.de>
Gerrit-HasComments: Yes

Reply via email to