neels has posted comments on this change. ( 
https://gerrit.osmocom.org/c/osmo-sgsn/+/15211 )

Change subject: Introduce and use log macros when no mm ctx available
......................................................................


Patch Set 1: Code-Review+1

(4 comments)

https://gerrit.osmocom.org/#/c/15211/1/include/osmocom/sgsn/gprs_sgsn.h
File include/osmocom/sgsn/gprs_sgsn.h:

https://gerrit.osmocom.org/#/c/15211/1/include/osmocom/sgsn/gprs_sgsn.h@264
PS1, Line 264: #define LOGIUP(level, ue, fmt, args...) \
(cosmetic)

hmm, I see that LOGMMCTXP() also has level as first arg, but AFAIK all the rest 
of the Osmocom code base uses this order:

  LOGFOO(object, level, fmt, args...)

Probably not worth the effort, but I'd prefer new LOG macros to be consistent 
with that ordering, and maybe one day use sed to adjust LOGMMCTXP() to that 
order as well...?


https://gerrit.osmocom.org/#/c/15211/1/include/osmocom/sgsn/gprs_sgsn.h@284
PS1, Line 284:
(in osmo-msc and -bsc I named the logging macros more like LOG_HO and 
LOG_MSC_A, for readability. Here that would be LOG_IU, LOG_GB... I'd prefer 
that but you decide.)


https://gerrit.osmocom.org/#/c/15211/1/src/gprs/gprs_gmm.c
File src/gprs/gprs_gmm.c:

https://gerrit.osmocom.org/#/c/15211/1/src/gprs/gprs_gmm.c@185
PS1, Line 185:          LOGIUP(LOGL_NOTICE, ctx, "Cannot find mm ctx for IU 
event %d\n", type); \
(we have a value string for those events, see ranap_iu_event_type_str() from 
iu_client.h)


https://gerrit.osmocom.org/#/c/15211/1/src/gprs/gprs_gmm.c@221
PS1, Line 221:                  LOGIUP(LOGL_NOTICE, ctx, "Unknown event 
received: %i\n", type);
ranap_iu_event_type_str()?



--
To view, visit https://gerrit.osmocom.org/c/osmo-sgsn/+/15211
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-sgsn
Gerrit-Branch: master
Gerrit-Change-Id: Iba22060d8646bc8ec6227684ccb91d98cb4c7be2
Gerrit-Change-Number: 15211
Gerrit-PatchSet: 1
Gerrit-Owner: pespin <pes...@sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: neels <nhofm...@sysmocom.de>
Gerrit-Comment-Date: Wed, 14 Aug 2019 23:52:46 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment

Reply via email to