On 04/07/2017 01:51 PM, Duy Nguyen wrote:
> On Fri, Mar 31, 2017 at 9:11 PM, Michael Haggerty <mhag...@alum.mit.edu> 
> wrote:
>> Use reference iteration rather than do_for_each_entry_in_dir() in the
>> definition of files_pack_refs().
> 
> A "why" is missing here. My guess is readability/maintainability
> because it's easier to follow the code with iterator design, than the
> callback one? No maintaining data in struct pack_refs_cb_data is also
> very nice.

You're right. I'll improve the commit message to something like

files_pack_refs(): use reference iteration

Use reference iteration rather than `do_for_each_entry_in_dir()` in the
definition of `files_pack_refs()`. This makes the code shorter and
easier to follow, because the logic can be inline rather than spread
between the main function and a callback function, and it removes the
need to use `pack_refs_cb_data` to preserve intermediate state.

This removes the last callers of `entry_resolves_to_object()` and
`get_loose_ref_dir()`, so delete those functions.

Thanks,
Michael

Reply via email to