On Wed, Jun 21, 2017 at 1:09 PM, Junio C Hamano <gits...@pobox.com> wrote:
> Jonathan Tan <jonathanta...@google.com> writes:
>
>> On Mon, 19 Jun 2017 19:48:01 -0700
>> Stefan Beller <sbel...@google.com> wrote:
>>
>>> @@ -676,6 +677,14 @@ static void emit_diff_symbol(struct diff_options *o, 
>>> enum diff_symbol s,
>>>              }
>>>              emit_line(o, context, reset, line, len);
>>>              break;
>>> +    case DIFF_SYMBOL_FILEPAIR:
>>> +            meta = diff_get_color_opt(o, DIFF_METAINFO);
>>> +            reset = diff_get_color_opt(o, DIFF_RESET);
>>> +            fprintf(o->file, "%s%s%s%s%s%s\n", diff_line_prefix(o), meta,
>>> +                    flags ? "+++ " : "--- ",
>>
>> I think that a constant should be defined for this flag, just like for
>> content lines. If not it is not immediately obvious that a flag should
>> be set for the +++ lines.
>
> True.
>
>>> +                    line, reset,
>>> +                    strchr(line, ' ') ? "\t" : "");
>>> +            break;
>
> Also this is somewhat misnamed in that a call to it only deals with
> one half of a filepair, iow, the caller must call it twice to show a
> single filepair.

Split into two and renamed to DIFF_SYMBOL_FILEPAIR_PLUS
and DIFF_SYMBOL_FILEPAIR_MINUS.

Thanks,
Stefan

Reply via email to