Phillip Wood <phillip.w...@talktalk.net> writes:

> From: Phillip Wood <phillip.w...@dunelm.org.uk>
>
> Recount the number of preimage and postimage lines in a hunk after it
> has been edited so any change in the number of insertions or deletions
> can be used to adjust the offsets of subsequent hunks. If an edited
> hunk is subsequently split then the offset correction will be lost. It
> would be possible to fix this if it is a problem, however the code
> here is still an improvement on the status quo for the common case
> where an edited hunk is applied without being split.
>
> This is also a necessary step to removing '--recount' and
> '--allow-overlap' from the invocation of 'git apply'. Before
> '--recount' can be removed the splitting and coalescing counting needs
> to be fixed to handle a missing newline at the end of a file. In order
> to remove '--allow-overlap' there needs to be i) some way of verifying
> the offset data in the edited hunk (probably by correlating the
> preimage (or postimage if the patch is going to be applied in reverse)
> lines of the edited and unedited versions to see if they are offset or
> if any leading/trailing context lines have been removed) and ii) a way of
> dealing with edited hunks that change context lines that are shared
> with neighbouring hunks.
>
> Signed-off-by: Phillip Wood <phillip.w...@dunelm.org.uk>
> ---

Thanks for clear description of what is going on in the series.

> diff --git a/git-add--interactive.perl b/git-add--interactive.perl
> index 7a0a5896bb..0df0c2aa06 100755
> --- a/git-add--interactive.perl
> +++ b/git-add--interactive.perl
> @@ -938,13 +938,19 @@ sub coalesce_overlapping_hunks {
>                                               parse_hunk_header($text->[0]);
>               unless ($_->{USE}) {
>                       $ofs_delta += $o_cnt - $n_cnt;
> +                     # If this hunk has been edited then subtract
> +                     # the delta that is due to the edit.
> +                     $_->{OFS_DELTA} and $ofs_delta -= $_->{OFS_DELTA};

The pattern

        <<conditional>> and <<statement with side effect>>;

is something you are newly introducing to this script.  I am not
sure if we want to see them.  I somehow find them harder to read
than the more straight-forward and naïve

        if (<<conditional>>) {
                <<statement with side effect>>;
        }


> +             # If this hunk was edited then adjust the offset delta
> +             # to reflect the edit.
> +             $_->{OFS_DELTA} and $ofs_delta += $_->{OFS_DELTA};

Likewise.

> +sub recount_edited_hunk {
> +     local $_;
> +     my ($oldtext, $newtext) = @_;
> +     my ($o_cnt, $n_cnt) = (0, 0);
> +     for (@{$newtext}[1..$#{$newtext}]) {
> +             my $mode = substr($_, 0, 1);
> +             if ($mode eq '-') {
> +                     $o_cnt++;
> +             } elsif ($mode eq '+') {
> +                     $n_cnt++;
> +             } elsif ($mode eq ' ') {
> +                     $o_cnt++;
> +                     $n_cnt++;
> +             }
> +     }
> +     my ($o_ofs, undef, $n_ofs, undef) =
> +                                     parse_hunk_header($newtext->[0]);
> +     $newtext->[0] = format_hunk_header($o_ofs, $o_cnt, $n_ofs, $n_cnt);
> +     my (undef, $orig_o_cnt, undef, $orig_n_cnt) =
> +                                     parse_hunk_header($oldtext->[0]);
> +     # Return the change in the number of lines inserted by this hunk
> +     return $orig_o_cnt - $orig_n_cnt - $o_cnt + $n_cnt;
> +}

OK.

> @@ -1114,25 +1144,32 @@ sub prompt_yesno {
>  }
>  
>  sub edit_hunk_loop {
> -     my ($head, $hunk, $ix) = @_;
> -     my $text = $hunk->[$ix]->{TEXT};
> +     my ($head, $hunks, $ix) = @_;
> +     my $hunk = $hunks->[$ix];
> +     my $text = $hunk->{TEXT};
> ...
> +             $newhunk->{OFS_DELTA} = recount_edited_hunk($text, $newtext);
> +             # If this hunk has already been edited then add the
> +             # offset delta of the previous edit to get the real
> +             # delta from the original unedited hunk.
> +             $hunk->{OFS_DELTA} and
> +                             $newhunk->{OFS_DELTA} += $hunk->{OFS_DELTA};

Ahh, good point.

Reply via email to