Han-Wen Nienhuys <han...@google.com> writes:

> The colorization is controlled with the config setting "color.remote".
> ...
> Finally, this solution is backwards compatible: many servers already
> prefix their messages with "error", and they will benefit from this
> change without requiring a server update. By contrast, a server-side
> solution would likely require plumbing the TERM variable through the
> git protocol, so it would require changes to both server and client.

Thanks; quite readable.

>
> Helped-by: Duy Nguyen <pclo...@gmail.com>
> Signed-off-by: Han-Wen Nienhuys <han...@google.com>
> ---
>  Documentation/config.txt            |   9 +++
>  help.c                              |   1 +
>  help.h                              |   1 +
>  sideband.c                          | 119 +++++++++++++++++++++++++---
>  t/t5409-colorize-remote-messages.sh |  47 +++++++++++
>  5 files changed, 168 insertions(+), 9 deletions(-)
>  create mode 100644 t/t5409-colorize-remote-messages.sh

I'll "chmod +x" while queuing.

        Side note: When all problems pointed out are "I'll fix it
        this way while queuing"-kind, and if you agree to the way I
        plan to fix them up, then just saying so is sufficient and
        you do not have to send a new version of the patch(es).

If your "make test" did not catch this as an error, then we may need
to fix t/Makefile, as it is supposed to run test-lint.

> diff --git a/Documentation/config.txt b/Documentation/config.txt
> index 43b2de7b5..0783323be 100644
> --- a/Documentation/config.txt
> +++ b/Documentation/config.txt
> @@ -1229,6 +1229,15 @@ color.push::
>  color.push.error::
>       Use customized color for push errors.
>  
> +color.remote::
> +     A boolean to enable/disable colored remote output. If unset,
> +     then the value of `color.ui` is used (`auto` by default).

Nobody tells the end-users what "colored remote output" does;
arguably they can find it out themselves by enabling the feature and
observing remote messages, but that is not user friendly.

        When running commands like `git fetch` and `git push` that
        interact with a remote repository, certain keywords (see
        `color.remote.<slot>`) that appear at the beginning of a
        line of message from the remote end can be painted in color.

        This configuration variable is a boolean to enable/disable
        the feature.  If unset...
        
or something like that, perhaps?

You use `always` in your tests to a good effect, but what the value
means is not described here.

> +color.remote.<slot>::
> +     Use customized color for each remote keywords. `<slot>` may be

Isn't 'each' a singular, i.e. "for each remote keyword"?  If so I do
not mind dropping 's' myself while queuing.

> +     `hint`, `warning`, `success` or `error` which match the
> +     corresponding keyword.

We need to say that keywords are painted case insensitively
somewhere in the doc.  Either do that here, or in the updated
description of `color.remote`---I am not sure which one results in
more readable text offhand.

> diff --git a/sideband.c b/sideband.c
> index 325bf0e97..5c72db83c 100644
> --- a/sideband.c
> +++ b/sideband.c
> @@ -1,6 +1,103 @@
>  #include "cache.h"
> +#include "color.h"
> +#include "config.h"
>  #include "pkt-line.h"
>  #include "sideband.h"
> +#include "help.h"
> +
> +struct kwtable {
> +     /*
> +      * We use keyword as config key so it can't contain funny chars like
> +      * spaces. When we do that, we need a separate field for slot name in
> +      * load_sideband_colors().
> +      */
> +     const char *keyword;
> +     char color[COLOR_MAXLEN];
> +};
> +
> +static struct kwtable keywords[] = {
> +     { "hint",       GIT_COLOR_YELLOW },
> +     { "warning",    GIT_COLOR_BOLD_YELLOW },
> +     { "success",    GIT_COLOR_BOLD_GREEN },
> +     { "error",      GIT_COLOR_BOLD_RED },
> +};
> +
> +// Returns a color setting (GIT_COLOR_NEVER, etc).
> +static int use_sideband_colors(void)
> +{
> +     static int use_sideband_colors_cached = -1;
> +
> +     const char *key = "color.remote";
> +     struct strbuf sb = STRBUF_INIT;
> +     char *value;
> +     int i;
> +
> +     if (use_sideband_colors_cached >= 0)
> +             return use_sideband_colors_cached;
> +
> +     if (!git_config_get_string(key, &value))
> +             use_sideband_colors_cached = git_config_colorbool(key, value);
> +
> +     for (i = 0; i < ARRAY_SIZE(keywords); i++) {
> +             strbuf_reset(&sb);
> +             strbuf_addf(&sb, "%s.%s", key, keywords[i].keyword);
> +             if (git_config_get_string(sb.buf, &value))
> +                     continue;
> +             if (color_parse(value, keywords[i].color))
> +                     die(_("expecting a color: %s"), value);
> +     }
> +     strbuf_release(&sb);
> +     return use_sideband_colors_cached;
> +}
> +
> +void list_config_color_sideband_slots(struct string_list *list, const char 
> *prefix)
> +{
> +     int i;
> +
> +     for (i = 0; i < ARRAY_SIZE(keywords); i++)
> +             list_config_item(list, prefix, keywords[i].keyword);
> +}
> +
> +/*
> + * Optionally highlight some keywords in remote output if they appear at the
> + * start of the line. This should be called for a single line only.
> + */
> +void maybe_colorize_sideband(struct strbuf *dest, const char *src, int n)
> +{
> +     int i;

In a block with a dozen more more lines, it is easier to have a
blank line between decls and the first statement, i.e. here.

> +     if (!want_color_stderr(use_sideband_colors())) {

The above line is indented with SP followed by HT; don't.

> +             strbuf_add(dest, src, n);
> +             return;
> +     }
> +
> +     while (isspace(*src)) {
> +             strbuf_addch(dest, *src);
> +             src++;
> +             n--;
> +     }
> +
> +     for (i = 0; i < ARRAY_SIZE(keywords); i++) {
> +             struct kwtable* p = keywords + i;

        struct kwtable *p = keywords + i;

> +             int len = strlen(p->keyword);
> +                /*
> +                 * Match case insensitively, so we colorize output from 
> existing
> +                 * servers regardless of the case that they use for their
> +                 * messages. We only highlight the word precisely, so
> +                 * "successful" stays uncolored.
> +                 */

Indent with tabs, not a run of spaces, i.e. 

                int len = strlen(p->keyword);
                /*
                 * Match case insensitively, so we colorize output from existing
                 * servers regardless of the case that they use for their
                 * messages. We only highlight the word precisely, so
                 * "successful" stays uncolored.
                 */
                if (!strncasecmp(p->keyword, src, len) && !isalnum(src[len])) {

The code in this function looked OK otherwise.

> diff --git a/t/t5409-colorize-remote-messages.sh 
> b/t/t5409-colorize-remote-messages.sh
> new file mode 100644
> index 000000000..4e1bd421f
> --- /dev/null
> +++ b/t/t5409-colorize-remote-messages.sh
> @@ -0,0 +1,47 @@
> +#!/bin/sh
> +
> +test_description='remote messages are colorized on the client'
> +
> +. ./test-lib.sh
> +
> +test_expect_success 'setup' '
> +     mkdir .git/hooks &&

> +     cat << EOF > .git/hooks/update &&
> +#!/bin/sh
> +echo error: error
> +echo hint: hint
> +echo success: success
> +echo warning: warning
> +echo prefixerror: error
> +exit 0
> +EOF
> +     chmod +x .git/hooks/update &&

Use write_script, i.e. instead of all the above, say

        write_script .git/hooks/update <<-\EOF &&
        echo error: error
        echo hint: hint
        ...
        exit 0
        EOF

so that you do not have to know or care the case where /bin/sh is
not the builder's preferred shell, etc.

Our tests are not written to demonstrate that our code works as
written.  It is to protect our code from getting broken by others
who may not share vision of the original author.  Make sure that you
cast what you care about in stone, e.g. include "echo ERROR: bad" or
something in the above to ensure that future updates to the code
will not turn the match into a case sensitive one without breaking
the test suite.

> +     echo 1 >file &&
> +     git add file &&
> +     git commit -m 1 &&
> +     git clone . child &&
> +     cd child &&
> +     echo 2 > file &&
> +     git commit -a -m 2

Don't chdir the whole testing environment like this.  Depending on
the success and failure in the middle of the above &&-chain, the
next test will start at an unexpected place, which is bad.

Instead, do something like

        git clone . child &&
        echo 2 >child/file &&
        git -C child commit -a -m 2

or

        git clone . child &&
        (
                cd child &&
                echo 2 >file &&
                git commit -a -m 2
        )

> +'
> +
> +test_expect_success 'push' '
> +     git -c color.remote=always push -f origin HEAD:refs/heads/newbranch 
> 2>output &&
> +     test_decode_color <output >decoded &&
> +     grep "<BOLD;RED>error<RESET>:" decoded &&
> +     grep "<YELLOW>hint<RESET>:" decoded &&
> +     grep "<BOLD;GREEN>success<RESET>:" decoded &&
> +     grep "<BOLD;YELLOW>warning<RESET>:" decoded &&
> +     grep "prefixerror: error" decoded

A comment before this test (which covers both of these two) that
explains why many "grep" invocations are necessary, instead of a
comparison with a single multi-line expected result file.  I am
guessing that it is *not* because you cannot rely on the order of
these lines coming out from the update hook, but because the remote
output have lines other than what is given by the update hook and
we cannot afford to write them in the expected result file.

A more readable alternative might be to prepare the message that
come from the other side more parseable, e.g.

        write_script .git/hooks/update <<-\EOF &&
        echo 'BEGIN HOOK OUTPUT
        error: error
        Error: another error
        ...
        END HOOK OUTPUT'
        EOF

and then

        sed -ne "/BEGIN HOOK OUTPUT/,/END HOOK OUTPUT/p" output |
        test_decode_color >decoded &&
        cat >expect <<-\EOF &&
        BEGIN HOOK OUTPUT
        <BOLD;RED>error<RESET>: error
        <BOLD;RED>Error<RESET>: another error
        ...
        END HOOK OUTPUT
        EOF
        test_cmp expect decoded

Then we do not have to make readers puzzled why we are using bunch
of "grep" and do not explain with an extra comment.

Thanks.

Reply via email to