Stefan Beller <stefanbel...@googlemail.com> writes:

> +     struct option builtin_repack_options[] = {
> +             OPT_BIT('a', NULL, &pack_everything,
> +                             N_("pack everything in a single pack"), 
> ALL_INTO_ONE),
> +             OPT_BIT('A', NULL, &pack_everything,
> +                             N_("same as -a, and turn unreachable objects 
> loose"),
> +                                LOOSEN_UNREACHABLE),

Micronit.

With the current version of the code in cmd_repack() that uses the
pack_everything variable this may not make a difference, but I think
this should logically be "LOOSEN_UNREACHABLE | ALL_INTO_ONE" instead,
and the code should check (pack_evertying & ALL_INTO_ONE) instead of
checking "!pack_everything".  You may want to add to this flag variable
a new bit that does _not_ cause it to pack everything into one.
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to