On 03/24/2014 01:56 PM, Michael Haggerty wrote: > Changes relative to v1: > > * Rename the functions associated with ref_transactions to be more > reminiscent of database transactions: > > * create_ref_transaction() -> ref_transaction_begin() > * free_ref_transaction() -> ref_transaction_rollback() > * queue_update_ref() -> ref_transaction_update() > * queue_create_ref() -> ref_transaction_create() > * queue_delete_ref() -> ref_transaction_delete() > * commit_ref_transaction() -> ref_transaction_commit()
Those new names look better. > * Fix backwards compatibility of "git update-ref --stdin -z"'s > handling of the "create" command: allow <newvalue> to be the empty > string, treating it the same zeros. But deprecate this usage. The changes related to that look good. The new documentation is much clearer than my old wording. Series v2 looks good to me except for my responses to individual commits. Thanks, -Brad -- To unsubscribe from this list: send the line "unsubscribe git" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html