On Tue, Apr 1, 2014 at 7:29 AM, Junio C Hamano <gits...@pobox.com> wrote:
> * nd/multiple-work-trees (2014-03-25) 28 commits
>  - count-objects: report unused files in $GIT_DIR/repos/...
>  - gc: support prune --repos
>  - gc: style change -- no SP before closing bracket
>  - prune: strategies for linked checkouts
>  - checkout: detach if the branch is already checked out elsewhere
>  - checkout: clean up half-prepared directories in --to mode
>  - checkout: support checking out into a new working directory
>  - use new wrapper write_file() for simple file writing
>  - wrapper.c: wrapper to open a file, fprintf then close
>  - setup.c: support multi-checkout repo setup
>  - setup.c: detect $GIT_COMMON_DIR check_repository_format_gently()
>  - setup.c: convert check_repository_format_gently to use strbuf
>  - setup.c: detect $GIT_COMMON_DIR in is_git_directory()
>  - setup.c: convert is_git_directory() to use strbuf
>  - git-stash: avoid hardcoding $GIT_DIR/logs/....
>  - *.sh: avoid hardcoding $GIT_DIR/hooks/...
>  - git-sh-setup.sh: use rev-parse --git-path to get $GIT_DIR/objects
>  - $GIT_COMMON_DIR: a new environment variable
>  - commit: use SEQ_DIR instead of hardcoding "sequencer"
>  - fast-import: use git_path() for accessing .git dir instead of get_git_dir()
>  - reflog: avoid constructing .lock path with git_path
>  - *.sh: respect $GIT_INDEX_FILE
>  - git_path(): be aware of file relocation in $GIT_DIR
>  - path.c: group git_path(), git_pathdup() and strbuf_git_path() together
>  - path.c: rename vsnpath() to do_git_path()
>  - git_snpath(): retire and replace with strbuf_git_path()
>  - path.c: make get_pathname() call sites return const char *
>  - path.c: make get_pathname() return strbuf instead of static buffer
>
>  A replacement for contrib/workdir/git-new-workdir that does not
>  rely on symbolic links and make sharing of objects and refs safer
>  by making the borrowee and borrowers aware of each other.
>
>  What is the doneness of this thing?  I remember reading it through
>  once and sent review comments on earlier parts, but have there been
>  a lot of discussions on this topic?

The basic support is there. Some bells and whistles (e.g. listing
checkouts) are not, but we can add them when we see the needs. Eric
and Torsten helped review but no, there hasn't much discussion about
it, which may be because it's already perfect, or people are not
interested. Unfortunately, this multiple checkout thing conflicts with
how I use emacs (--daemon) so I'm not one of its heavy users either. I
only occastionally make new, short-lived checkouts to test things.
-- 
Duy
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to