On 04/01/2014 05:58 PM, Michael Haggerty wrote:
Reduce the amount of code that has to know about the lock_file's
filename field.
Signed-off-by: Michael Haggerty <mhag...@alum.mit.edu>
---
config.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/config.c b/config.c
index 6821cef..1ea3f39 100644
--- a/config.c
+++ b/config.c
@@ -1303,9 +1303,9 @@ static int store_aux(const char *key, const char *value,
void *cb)
return 0;
}
-static int write_error(const char *filename)
+static int write_error(struct lock_file *lk)
Does the write_error() really need to know about struct lock_file ?
(The name of the function does not indicate that it is doing something
with lk)
And if, would it make sense to rename it into
write_error_and_do_something() ?
{
- error("failed to write new configuration file %s", filename);
+ error("failed to write new configuration file %s", lk->filename);
/* Same error code as "failed to rename". */
return 4;
@@ -1706,7 +1706,7 @@ out_free:
return ret;
write_err_out:
- ret = write_error(lock->filename);
+ ret = write_error(lock);
goto out_free;
}
@@ -1821,7 +1821,7 @@ int git_config_rename_section_in_file(const char
*config_filename,
}
store.baselen = strlen(new_name);
if (!store_write_section(out_fd, new_name)) {
- ret = write_error(lock->filename);
+ ret = write_error(lock);
goto out;
}
/*
@@ -1847,7 +1847,7 @@ int git_config_rename_section_in_file(const char
*config_filename,
continue;
length = strlen(output);
if (write_in_full(out_fd, output, length) != length) {
- ret = write_error(lock->filename);
+ ret = write_error(lock);
goto out;
}
}
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html